Информатика, вопрос задал lizamameteva , 8 лет назад

Не особо шарю в паскале. Нужна помощь. Нужно написать программу для определения какой четверти принадлежит точка. Мне не нужно решение из интернета, без комментариев и прочего. По возможности с объяснением, а то дальше не вытяну информатику

Ответы на вопрос

Ответил DeSex
0
var  x,y:integer; 
begin
writeln('Программа определения местонахождения точки');
writeln('Введите координаты точки');
readln(x,y); //вводим координаты точки 
if (x>=0) and (y>=0) then writeln('1 четверть'); //точка принадлежит 1 ч. если обе координаты положительны (это из геометрии)
if (x<0) and (y>=0) then writeln('2 четверть'); //точка принадлежит 2 ч. если х<0, а y неотрицателен (это из геометрии)
if (x<0) and (y<0) then writeln('3 четверть'); //точка принадлежит 3 ч. если обе координаты отрицательны (это из геометрии)
if (x>=0) and (y<0) then writeln('4 четверть'); //точка принадлежит 4 ч. если х неотрицателен, а y<0 (это из геометрии)
end.  
Ответил lizamameteva
0
я смотрю просто классные работы из тетради и каждая программа начинается с var, begin, writeln например ('Решение квадратного уравнения') и write ('Введите ...')
Ответил lizamameteva
0
хахахха, спасибо
Новые вопросы