Информатика, вопрос задал boooo8 , 2 года назад

Найти сумму первых n элементов. Написать программу, если можно на Паскале. Pls, help

Приложения:

Ответы на вопрос

Ответил angryfukse
7

var

 arr: array of real;

 sum: real;

 size, n, i: integer;

begin

 sum := 0;

 writeln('Введите размерность массива: ');

 readln(size);

 arr := new real[size];

 for i := 0 to size - 1 do

   arr[i] := 1 / power(2, i) + 1 / power(3, i);

 writeln('До какого элемента нужно считать сумму?');

 readln(n);

 for i := 0 to n - 1 do

   sum := sum + arr[i];

 writeln('Сумма первых n элементов = ', sum);

end.

Новые вопросы