Найти сумму и произведение элементов массива, полученных случайным образом из отрезка [-10;20] Паскаль. Написать программу
Помогите решить, пожалуйста. Срочно!
МультаиНазар:
Тоесть random() от -10 до 20?
Ответы на вопрос
Ответил МультаиНазар
1
var n,i,k,k1:integer;
a:array[1..1000]of integer;
begin
k:=0;
k1:=1;
read(n); //СДЕСЬ ВВОДИТСЯ КОЛИЧЕСТВО ЭЛЕМЕНТОВ В МАССИВЕ!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
for i:=1 to n do
Begin
randomize;
a[i]:=random(31)-10;
end;
for i:=1 to n do
begin
k:=k+a[i];
k1:=k1*a[i];
end;
for i:=1 to n do
write(a[i],' ');
writeln(k);//СУММА
writeln(k1); //ПРОИЗВЕДЕНИЕ
end.
a:array[1..1000]of integer;
begin
k:=0;
k1:=1;
read(n); //СДЕСЬ ВВОДИТСЯ КОЛИЧЕСТВО ЭЛЕМЕНТОВ В МАССИВЕ!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
for i:=1 to n do
Begin
randomize;
a[i]:=random(31)-10;
end;
for i:=1 to n do
begin
k:=k+a[i];
k1:=k1*a[i];
end;
for i:=1 to n do
write(a[i],' ');
writeln(k);//СУММА
writeln(k1); //ПРОИЗВЕДЕНИЕ
end.
Новые вопросы
Английский язык,
1 год назад
Английский язык,
1 год назад
Алгебра,
2 года назад
Математика,
2 года назад
Геометрия,
7 лет назад