найти произведение элементов в каждом столбце массива размером MxN, элементы которого вводятся с клавиатуры
помогите пожалуйста написать программу по Паскаль
Ответы на вопрос
Ответил Аноним
1
Ответ:
const m=2;
n=2;
var p,i,j:integer;
a: array [1..n,1..m] of integer;
begin
for i:=1 to m do
for j:=1 to n do begin
read(a[i,j]);
end;
for i:=1 to n do begin
p:=1;
for j:=1 to m do begin
p:=p*a[j,i];
end;
writeln(p);
end;
end.
Объяснение:
m и n можно менять на любые числа
Приложения:

hayastan51:
от души!)
m=2;
n=2;
var p, i, j:Integer;
a: array [1..n,1..m] of Integer ;
begin ;
i:=1 to m do;
j:=1 to n do begin ;
read (a[i,j]);
end;
i:=1 to n do begin;
p:=1;
j:=1 to m do begin ;
p:=p*a[j,i];
end;
WriteLn(p);
end;
end.
Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад
Геометрия,
8 лет назад
Обществознание,
8 лет назад