НАЙДИТЕ ОШИБКУ В КОДЕ!
задание:Написать программу, которая бы рассчитывала значение выражения по формуле: (ln|cos(x)|)/(ln(1+x^2).
Мой код:
Program formula;
var
x:integer;
y:real;
begin
write('vvedute x ');
readln(x);
y:=(ln(abs(cos(x))))/ln(1+cos(x*x));
writeln('y=',y:5:2);
end.
почему то выдаёт ошибку. что не так?
Ответы на вопрос
Ответил Аноним
0
program formula;
var
x:integer;
p,y:real;
begin
Write('vvedute x<>0 ->');
Readln(x);
if x=0 then Writeln('x=0 nedopustimo')
else begin
p:= abs(cos(x));
if p=0 then Writeln('ln(0) v 4islitele')
else begin
y:=ln(p)/ln(1+sqr(x*x));
Writeln('y=',y:5:2)
end
end
end.
var
x:integer;
p,y:real;
begin
Write('vvedute x<>0 ->');
Readln(x);
if x=0 then Writeln('x=0 nedopustimo')
else begin
p:= abs(cos(x));
if p=0 then Writeln('ln(0) v 4islitele')
else begin
y:=ln(p)/ln(1+sqr(x*x));
Writeln('y=',y:5:2)
end
end
end.
Новые вопросы
Геометрия,
2 года назад
Биология,
2 года назад
Химия,
9 лет назад
Литература,
9 лет назад
Математика,
10 лет назад
Алгебра,
10 лет назад