Информатика, вопрос задал SashaGed , 8 лет назад

Найдите ошибку плз program ideone;
var a:array[1 .. 250] of integer;
s,n,i:integer;
begin
write('Please enter length of the array: ');
readln(n);
for i:=0 to n do
begin
write ('Please enter an array item ');
readln (a[i]);
end;
s:=0;
for i:=1 to n do
s:=s+a[i];
writeln('s=',s);
end.


3 5 31

Ответы на вопрос

Ответил svgdhmso
0
Попробуй вместо строки 
for i:=0 to n do
Написать: 
for i:=1 to n do
Ответил SashaGed
0
Неа
Ответил petyaGavrikov
0
var a:array[1 .. 250] of integer;
s,n,i:integer;
begin
write('Please enter length of the array: ');
readln(n);
for i:=1 to n do
begin
write ('Please enter an array item ');
readln (a[i]);
end;
s:=0;
for i:=1 to n do
s:=s+a[i];
writeln('s=',s);
end.

Пример (в первой строке вводится количество элементов, далее - сами элементы):
Please enter length of the array: 5
Please enter an array item 3
Please enter an array item 8
Please enter an array item 2
Please enter an array item 4
Please enter an array item 6
s=23
Новые вопросы