Народ помогите. Задали в школе. Написать программу и сделать схему. Дана последовательность 5,10,15,20,25. Найти количество элементов больше некоторого числа. На pascal.Фото что проходили в школе на всякий случай.
Приложения:

Ответы на вопрос
Ответил petyaGavrikov
0
Если делать по образцу, то можно, например, так:
program kol;
var a,n,k:integer;
begin
write('n='); readln(n);
k:=0;a:=25;
while a>n do
begin k:=k+1; a:=a-5; end;
writeln('k=',k);
end.
Пример:
n=16
k=2
program kol;
var a,n,k:integer;
begin
write('n='); readln(n);
k:=0;a:=25;
while a>n do
begin k:=k+1; a:=a-5; end;
writeln('k=',k);
end.
Пример:
n=16
k=2
Ответил petyaGavrikov
0
Все-таки хочется отметить, что данную задачу можно решить и без цикла: program kol;
var n,k:integer;
begin
write('n='); readln(n);
if n<25 then k:=25 div 5 - n div 5 else k:=0;
write(' k=',k);end;
end.
var n,k:integer;
begin
write('n='); readln(n);
if n<25 then k:=25 div 5 - n div 5 else k:=0;
write(' k=',k);end;
end.
Новые вопросы