Напишите программу, запрашивающую три стороны треугольника А, В, С и вычисляющую его площадь по формуле Герона
Ответы на вопрос
Ответил Dezl98
0
Если паскаль, то форму сам знаешь как, наверное вот тебе тело.
var p,S,AB,BC,AC :real(если не работает, то Integer);
begin
readln(AB);
readln(BC);
readln(AC);
p:=(AB+BC+AC)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
Writeln(s)
end.
Поправь там знаки или ещё что-нибудь - я не в программе писал.
var p,S,AB,BC,AC :real(если не работает, то Integer);
begin
readln(AB);
readln(BC);
readln(AC);
p:=(AB+BC+AC)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
Writeln(s)
end.
Поправь там знаки или ещё что-нибудь - я не в программе писал.
Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
География,
10 лет назад
Алгебра,
10 лет назад
Алгебра,
10 лет назад