Напишите программу, выводящую true, если высказывание является истинным, и false в противном случае для утверждения: «Сумма цифр трехзначного числа х является четным числом». Значение числа Х вводится с клавиатуры.
Ответы на вопрос
Ответил AwePlaxa
0
var x:integer;
begin
writeln('Введите чилос x: ');
readln(x);
if x>= 100 then
if (not odd(x)) then
writeln('TRUE')
else
writeln('FALSE')
else
writeln('Число не трехзначное');
end.
Надеюсь правильно понял тебя и составил программу верно.
begin
writeln('Введите чилос x: ');
readln(x);
if x>= 100 then
if (not odd(x)) then
writeln('TRUE')
else
writeln('FALSE')
else
writeln('Число не трехзначное');
end.
Надеюсь правильно понял тебя и составил программу верно.
Ответил zloichibak
0
Ок,а что такое else?
Ответил AwePlaxa
0
читается как "Иначе"
то есть у тебя проверяется условие.Если оно верно,выполняется команда1 иначе выполняется команда2
то есть у тебя проверяется условие.Если оно верно,выполняется команда1 иначе выполняется команда2
Ответил AwePlaxa
0
:)
Новые вопросы
Русский язык,
2 года назад
Французский язык,
2 года назад
Литература,
9 лет назад
Информатика,
9 лет назад
История,
10 лет назад
Математика,
10 лет назад