Информатика, вопрос задал miroslav201420 , 8 лет назад

Напишите программу, вычисляющую сумму всех нечетных чисел от 1 до н, использовать цикл с постусловием

Ответы на вопрос

Ответил contrlc
0
var
  n, i, s: integer;
 
begin
  s := 0;
  i := 0;
  read(n);
  repeat i := i + 1;
    if(i mod 2 <> 0) then s := s + i;
  until i = n;
  write(s);
end.
Новые вопросы