Информатика, вопрос задал dbuzinkin , 2 года назад

Напишите программу вычисляющую сумму элементов массива (в массиве 23 элемента). Все массивы заполняются случайным образом. Составить алгоритм решения задачи и написать программный код на языке Паскаль.

Ответы на вопрос

Ответил kseniamay184
0

Ответ:

1.

program z_1;

var i,s;intger;  

a:array [1..50] of integer;

begin

for i:=1 to 50 do

begin

readln(a[i]);

s:=s+a[i];

end;

writeln(s);

end.

2.

program z_2;

var c1,c2,pp:integer;

begin

readln(c1);

readln(c2);

pp:=round((c1*c2)/2);//полупроизведение двух чисел

writeln(pp);

end.

3.

program z_3;

var k,v,s:integer;

begin

readln(k);//Стоимость книги

readln(v);//Внесено денег

if k=v then

writeln('Спасибо!')

else

if k<v then

writeln('Возьмите сдачу : ',v-k)

else

writeln('Недостаточно средств : ',k-v);

end.

Объяснение:


dbuzinkin: это что?!
Новые вопросы