Информатика, вопрос задал Igor64890654 , 7 лет назад

Напишите программу, вычисляющую и выводящую n первых членов последовательности Фибоначчи. Нужна программа в паскале

Ответы на вопрос

Ответил Ziorar
0

1) В старом стиле Паскаля (тут используется тип uint64, а он достаточен только до n=93):


var

 n, i: Integer;

 a, b, c: uint64;


begin

 Writeln('Печать n первых членов последовательности Фибоначчи');

 Write('Введите n: ');

 Read(n);

 a := 1;

 b := 1;

 for i := 1 to n do

 begin

   writeln('n=', i, '  ', a);

   c := a + b;

   a := b;

   b := c;

 end;

end.


2) Используя возможности PascalABC.NET (тут уже есть тип BigInteger -неограниченное цело число):


var a, b: BigInteger;

begin

 Writeln('Печать n первых членов последовательности Фибоначчи');

 var n := ReadInteger('Введите n:');

 (a, b) := (1, 1);

 for var i := 1 to n do

 begin

   writeln('n=', i, '  ', a);

   (a, b) := (b, a + b);

 end;

end.

Приложения:
Новые вопросы