Напишите программу, вычисляющую
а) сумму n первых натуральных четных чисел;
б) произведение n первых натуральных нечетных чисел.
Ответы на вопрос
program dimavdovuskin497;
type t1 = integer;
t2 = double;
var n, i: t1;
x, summa, pr: t2;
begin
writeln('Напишите программу, вычисляющую: а) сумму n первых натуральных четных чисел; б) произведение n первых натуральных нечетных чисел.');
writeln;
write('Введите общее количество чисел: ');
readln(n);
writeln;
summa := 0;
pr := 1;
for i := 1 to n do
begin
write('Введите х: ');
readln(x);
writeln;
if (frac(x) = 0) then
begin
if (frac(x/2) = 0) then summa := summa + x
else pr := pr * x;
end;
end;
writeln('Сумма n первых натуральных четных чисел равна ', summa : 5 : 0);
writeln;
writeln('Произведение n первых натуральных нечетных чисел равно', pr : 5 : 0);
readln;
end.