Информатика, вопрос задал MaryLW1 , 2 года назад

Напишите программу вычисления выражения: (паскаль)

s =1!+2!+3!+...+ н!

Используйте ПРОЦЕДУРУ вычисления факториала!


MaryLW1: на паскале(

Ответы на вопрос

Ответил pinguinbird
0

Ответ:

var a,b,i,c,l:integer;

procedure F(n:integer);

begin

   a:=a*n;

end;

begin

   c:=0;

   a:=1;

   write('Введите количество аргументов: '); readln(l);

   for i:=1 to l do begin

       F(i);

       c:=c+a;

   end;

   write(c);

end.


MaryLW1: не работает\
MaryLW1: РАБОТАЕТ!!!!!!!!!!!!!!!
pinguinbird: круто! только я беспокоюсь, что может быть процедуру надо немного по-другому написать
pinguinbird: в принципе так тоже правильно работает
pinguinbird: Так, наверное, будет более правильно в рамках задания, но менее оптимально в рамках вычислительных ресурсов:
pinguinbird: var a,b,i,c,l:integer;

procedure F(n:integer);
var j:integer;
begin
for j:=1 to n do a:=a*j;
end;

begin
c:=0;
write('Введите количество аргументов: '); readln(l);
for i:=1 to l do begin
a:=1;
F(i);
c:=c+a;
end;
write(c);
end.
Новые вопросы