Информатика, вопрос задал ученик2884 , 9 лет назад

напишите программу вычисления суммы чисел кратных 5 из натурального ряда чисел от 1 до n , и произведение чисел кратных к 3 (for)

Ответы на вопрос

Ответил ychilkati
0
var
  i, s, p :integer;
begin
write ('n=');
readln (n);
s:=0;
p:=1;
  for i:=1 to n do
   
 begin
     if i mod 5=0 then  s:=s+i;
    
 if i mod 3=0 then  p:=p*i
    end;
  Writeln ('s=', s, '   p=', p)
end.

Новые вопросы