Напишите программу вычисления общего члена Bn и суммы Sn первых n членов геометрической прогрессии. Первый член прогрессии b1, знаменатель прогрессии q и число членов задаются с клавиатуры.
По этим формулам
Приложения:

Ответы на вопрос
Ответил MrFasty5
0
var bn,sn,b1,q,n:real;
begin
write('b1=');
read(b1);
write('q=');
read(q);
write('n=');
read(n);
bn:=b1*power(q,n-1);
sn:=(b1*(power(q,n)-1))/(q-1);
writeln('Bn=',bn);
writeln('Sn=',sn);
end.
Ответил MrFasty5
0
отметьте пожалуйста как лучшее
Новые вопросы
Другие предметы,
2 года назад
Русский язык,
2 года назад
Химия,
7 лет назад
Математика,
7 лет назад
География,
9 лет назад