Информатика, вопрос задал romabryuxachev , 7 лет назад

напишите программу вычисления наибольшего общего делителя двух целых чисел.
а)с оператором repeat
б) с оператором while

Ответы на вопрос

Ответил 2ReCKey
0

по алгоритму евклида:

var a,b:integer;

begin

 readln(a,b);

 repeat

   if a>b then

     a:=a mod b

   else

     b:=b mod a;

 until (a=0) or (b=0);

 writeln(a+b);

end.

-------------------------

var a,b:integer;

begin

 readln(a,b);

 while (a<>0) and (b<>0) do

   if a>b then

       a:=a mod b

     else

       b:=b mod a;

 writeln(a+b);

end.

Новые вопросы