Информатика, вопрос задал профффффи , 8 лет назад

напишите программу: ввести с клавиатуры массив из 8 элементов. Найти сумму элементов кратных 6

Ответы на вопрос

Ответил ragoon
0
#include <stdio.h>

#define N 8

int A;

void main(void)
{
int      i, Sum =0;
float   check;

for(i = 0, i<N, i++) {
     printf ("nВведите элемент номер %d", i);
     scanf("%d", &A);
     check = A/6.0
     if ((int)check == A%6) Sum+=A;
     }
printf ("Сумма элементов, кратных 6 равна %d", Sum);
}

Ответил профффффи
0
в паскале нужно
Ответил ragoon
0
Да? И что же ты раньше-то молчала?
Ответил Aillianna
0
а почему нельзя сразу (0 == A%6) ? просто интересно
Ответил ragoon
0
Можно. Это яркий пример того, что сделать сложно проще, чем добиться того же результата, сделав просто. Я просто давненько не писал. :-(
Ответил Aillianna
0
увы проверить программу не могу так как не на чем. А вообще код вроде выглядит верным
Новые вопросы