Напишите программу винипух съедает 100 грамм варенья первый день, во второй день еще 100 грамм варенья, в третий день 200 грамм варенья, в каждый последующий день он съедает кол-во варенья равное сумме количества варенья в 2 прошедших днях. За сколько дней он съест К грамм варенья
Приложения:

Ответы на вопрос
Ответил roulen
0
program Vinni;
var x,x1,x2,x3,y,sum:integer;
begin
writeln('введите кол-во грамм');
readln(x);if x<100 then writeln('меншье чем за час :)');
if x=100 then writeln('столько он скушает за 1 день');
if (x>100) and (x<200) then writeln('от 1 до 2 дней не включая их');
if x=200 then writeln('за два первых дня он скушает столько!)');
if x>200 then begin
x1:=100;
x2:=100;
x3:=200;
y:=2;
sum:=200;
repeat
if sum<=x then begin x2:=x1+x3; sum:=sum+x2; y:=y+1; end;
if sum<=x then begin x1:=x2+x3; y:=y+1; sum:=sum+x1; end;
if sum<=x then begin x3:=x1+x2; sum:=sum+x3; y:=y+1; end;
until (sum>=x) or (sum>=x) or (sum>=x);writeln(y);
end;
end.
var x,x1,x2,x3,y,sum:integer;
begin
writeln('введите кол-во грамм');
readln(x);if x<100 then writeln('меншье чем за час :)');
if x=100 then writeln('столько он скушает за 1 день');
if (x>100) and (x<200) then writeln('от 1 до 2 дней не включая их');
if x=200 then writeln('за два первых дня он скушает столько!)');
if x>200 then begin
x1:=100;
x2:=100;
x3:=200;
y:=2;
sum:=200;
repeat
if sum<=x then begin x2:=x1+x3; sum:=sum+x2; y:=y+1; end;
if sum<=x then begin x1:=x2+x3; y:=y+1; sum:=sum+x1; end;
if sum<=x then begin x3:=x1+x2; sum:=sum+x3; y:=y+1; end;
until (sum>=x) or (sum>=x) or (sum>=x);writeln(y);
end;
end.
Ответил roulen
0
нет, смотрите. 1-й день 100, 2-й день 100, 3-й день 200. А за первые три дня - 400.
Ответил roulen
0
введите кол-во грамм
400
3
400
3
Ответил roulen
0
3 верный ответ
Ответил pavel781
0
всё понял
Новые вопросы
Математика,
2 года назад
Другие предметы,
2 года назад
Физика,
8 лет назад
Математика,
8 лет назад
Литература,
9 лет назад