Информатика, вопрос задал Football14 , 9 лет назад

Напишите программу в ТУРБО ПАСКАЛЕ
Введите с клавиатуры переменные c и d. Если 0<c<d, то нарисуйте квадрат со стороной 2d. Иначе нарисуйте отрезок с концами в точках (c,c) и (d,d).

Ответы на вопрос

Ответил Аноним
0
uses Graph; { Подключаем модуль }
var
  c,d,Gd,Gm:integer;
  k:real;
begin
  Writeln('10<=c<=460; 10<=d<=230');
  Write('Задайте c в пределах от 10 до 460: ');Read(c);
  if (c<10) or (c>460) then Writeln('Неверное значение!')
  else begin
    Write('Задайте d в пределах от 10 до 230: '); Readln(d);
    if (d<10) or (d>230) then Writeln('Неверное значение!')
    else begin
      Gd := Detect;
      InitGraph(Gd, Gm, 'Y:tp7bgi'); { Инициализируем графический режим }
      SetColor(4);
      k:=GetMaxX/GetMaxY; { Коэффициент искажений по осям }
      if c<d then Rectangle(Trunc(10/k),10,Trunc((2*d+10)/k),2*d+10)
      else Line(Trunc(c/k),c,Trunc(d/k),d);
      Readln;
      CloseGraph
    end
  end
end.

Ответил Аноним
0
'Y:tp7bgi' - это путь к папке BGI Турбо Паскаль
Ответил Football14
0
А зачем нам указывать путь к папке Паскаля?
Ответил Аноним
0
Так построена графическая подсистема у Турбопаскаль. Но если Вы будете запускать Турбопаскаль из его директории, то вместо пути можно указать строку из одного или более пробелов. Потому что этот путь используется тогда, когда папка BGI не видна из директории запуска.
Ответил Аноним
0
Видите первый оператор uses Graph? Он задает Турбопаскалю приказ найти файлы графики *.bgi, а по умолчанию они лежат в поддиректории BGI
Новые вопросы