Напишите программу в turbo pascal: найти корни квадратного уравнения ax^2+bx+c
Ответы на вопрос
Ответил hardmad
1
var a,b,c,d,x,x1,x2:real;
begin
readln(a.b.c);
d:=sqr(b) - 4*a*c;
if d<0 then
write('нет корней')
else
If d=0 then begin
x:=-b/(2*a);
write(x); end
else begin
x1:=(-b+sqrt(d)/(2*a);
x2:=(-b-sqrt(d))/(2*a);
write(x1,x2);end;
readln
end.
begin
readln(a.b.c);
d:=sqr(b) - 4*a*c;
if d<0 then
write('нет корней')
else
If d=0 then begin
x:=-b/(2*a);
write(x); end
else begin
x1:=(-b+sqrt(d)/(2*a);
x2:=(-b-sqrt(d))/(2*a);
write(x1,x2);end;
readln
end.
Izvest:
Ты даже не представляешь, как ты меня выручил, я долго не мог нужный порядок действий составить, а по скольку я на домашнем обучении из за проблем со здоровьем, мне с утра позвонил учитель информатики, что бы проверить как я д/з сделал, я быстро открываю твой ответ, проговорил ей эту программу (ну еще я блок схему сделал тоже, но это не так важно) и у меня пятерочка все таки вышла! Спасибо тебе огромное, от души!!))
Новые вопросы
Другие предметы,
1 год назад
Английский язык,
1 год назад
Физика,
2 года назад
Информатика,
7 лет назад