Информатика, вопрос задал Rubakaplya , 1 год назад

Напишите программу в среде программирования
PascalABC. Протестируйте ее.
Составьте программу нахождения и вывода на экран номера первого четного элемента целочисленного массива из 8 элементов или выведите на экран сообщение о том, что четных элементов в массиве нет. В качестве ответа напишите код вашей программы (учитывая
синтаксис
языка
программирования Pascal).

Ответы на вопрос

Ответил andreyfedyanovich
1

program FindFirstEven;

const

 n = 8; // Кількість елементів у масиві

var

 arr: array[1..n] of integer; // Оголошення масиву

 i: integer; // Лічильник

 firstEven: integer = -1; // Номер першого четного елемента, -1 як прапорець

begin

 // Заповнення масиву

 for i := 1 to n do

 begin

   writeln('Введіть елемент ', i, ': ');

   readln(arr[i]);

 end;

 // Пошук першого четного елемента

 for i := 1 to n do

 begin

   if arr[i] mod 2 = 0 then // Якщо число є парним

   begin

     firstEven := i; // Запам'ятовуємо номер четного елемента

     Break; // Вихід з циклу, якщо знайдено перший четний елемент

   end;

 end;

 // Виведення результату

 if firstEven <> -1 then

   writeln('Номер першого четного елемента: ', firstEven)

 else

   writeln('В масиві немає четних елементів.');

 readln;

end.

Новые вопросы