Информатика, вопрос задал kolppolkkolp , 8 лет назад

Напишите программу в среде паскаль
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 2.
Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 2.
Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, оканчивающееся на 2.

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadlnInteger;
  Writeln(ReadSeqInteger(n).Where(i->abs(i) mod 10=2).Max)
end.

Пример
18
-11 12 -4 -35 -32 -16 -23 -22 31 -10 2 -29 47 49 42 47 31 -44
42
Новые вопросы