напишите программу в среде Pascal ABC,которая в последовательности чисел от 5 до 30 находит произведение чётных.
Ответы на вопрос
Ответил fofgogjoj
0
Program fofgogjoj;
Var
a: array [1..100] of integer;
i, n, p: integer;
Begin
p:=1;
n:=30;
for i:=5 to n do
begin
a[i]:=i;
if i mod 2=0 then
p:=p*a[i];
end;
Writeln ('Произведение элементов массива с четными числами равно: ',p);
End.
Var
a: array [1..100] of integer;
i, n, p: integer;
Begin
p:=1;
n:=30;
for i:=5 to n do
begin
a[i]:=i;
if i mod 2=0 then
p:=p*a[i];
end;
Writeln ('Произведение элементов массива с четными числами равно: ',p);
End.
Ответил sayaf
0
мы так не делали,но я подредактировал до такого вида:Var
i,p: integer;
Begin
p:=1;
for i:=5 to 30 do
begin
if i mod 2=0 then
p:=p*i;
end;
Writeln ('Произведение',p);
End.
i,p: integer;
Begin
p:=1;
for i:=5 to 30 do
begin
if i mod 2=0 then
p:=p*i;
end;
Writeln ('Произведение',p);
End.
Ответил fofgogjoj
0
ну я не знаю же что вы делали, а что нет:)
Ответил fofgogjoj
0
у меня вариант с массивом
Ответил Вселенный
0
это очень сложно, не могу
Новые вопросы
Алгебра,
2 года назад
Математика,
2 года назад
Математика,
10 лет назад
География,
10 лет назад
Математика,
10 лет назад
История,
10 лет назад