Напишите программу, в результате выполнения которой первое введённое число уменьшается в три раза, если оно больше, чем третье, а третье становится разностью третьего и второго, если оно больше второго.
Ответы на вопрос
Ответил And42
0
var
number1, number2, number3 : real;
begin
write('Первое число: ');
readln(number1);
write('Второе число: ');
readln(number2);
write('Третье число: ');
readln(number3);
if (number1 > number3) then number1 := number1 / 3;
if (number3 > number2) then number3 := number3 - number2;
writeln('Вывод');
writeln('Первое число: ', number1);
writeln('Второе число: ', number2);
writeln('Третье число: ', number3);
end.
number1, number2, number3 : real;
begin
write('Первое число: ');
readln(number1);
write('Второе число: ');
readln(number2);
write('Третье число: ');
readln(number3);
if (number1 > number3) then number1 := number1 / 3;
if (number3 > number2) then number3 := number3 - number2;
writeln('Вывод');
writeln('Первое число: ', number1);
writeln('Второе число: ', number2);
writeln('Третье число: ', number3);
end.
Новые вопросы