Информатика, вопрос задал jemchujinkaaa777 , 7 лет назад

Напишите программу в ПИТОНЕ которая должна будет вывести одно число:сумму чисел,кратных 6 и оканчивающиеся на 8.
Входные данные:
3
18
25
48
Выходные данные:
66
Кто решит верно, отдам 100 баллов!!!​

Ответы на вопрос

Ответил matvey2207
1

Ответ:

def test(list_of_numbers):

   x = 0

   for num in list_of_numbers:

       if num % 6 == 0 and str(num).endswith('8'):

           x += num

   return x

Объяснение:

test([3, 18, 25, 48])

Возвращает 66, код работает правильно

Приложения:

jemchujinkaaa777: например что-бы найти просто чтоб программа вывела одно число кратных 6 и оканчивающиеся 8 то получится следующяя программа:
matvey2207: ну num % 6 == 0 проверяет чтоб число было кратным 6
matvey2207: а str(num).endswith('8') проверяет чтоб число кончалось на 8
jemchujinkaaa777: i = 1
amount = 0
n = int(input())
for i in range(n) a = int(input())
if a % 6 == 0 and a % 10 == 8:
amount = amount +1
print(amount)
jemchujinkaaa777: вот
matvey2207: ну код почти похож на мой ,_,
matvey2207: просто числа передаются как аргументы функции
jemchujinkaaa777: мне нужно таким способом и как-то ещё найти сумму
matvey2207: ну так создаёшь какую-то переменную со значением 0
jemchujinkaaa777: потом
Ответил restIess
2

Научитесь грамотно писать, что конкретно Вы хотите.

Правильно задание должно звучать так:

Напишите программу в Python для новичка, сначала на вход программе подается число - количество чисел в последовательности, а затем сами элементы(целые) последовательности (каждый элемент последовательности на новой строке), требуется вывести на экран сумму чисел, кратных 6 и оканчивающихся на 8.

Код:

_sum = 0

n = int(input())

for i in range(0, n):

   x = int(input())

   if x % 6 == 0 and x % 10 == 8:

       _sum += x

print(_sum)

       


jemchujinkaaa777: не правильно выводит 18,вместо 66
restIess: Мне выводит 66, табуляции возможно улетели
jemchujinkaaa777: как скопировать твою программу?
Новые вопросы