Информатика, вопрос задал Vitalii02 , 9 лет назад

Напишите программу в ПаскалеABC, выводящую n-ую цифру в последовательности натуральных чисел : 1234567891011...
Вводится число n до 100
При решении этой задачи нельзя использовать любой из видов условной инструкции if.
Вывести надо только ответ

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  var n:=ReadInteger('n=');
  Writeln(1.To((n+10) div 2).JoinIntoString('')[n]);
end.
Новые вопросы