напишите программу в паскале для решения квадратных уравнений
Ответы на вопрос
Ответил hello93
0
procedure solution(k,y,z : real);
var
D,x1,x,x2:real;
begin
D:=y*y-4*k*z;
if D>0 then
begin
x1:=(-y+sqrt(D))/2*k;
x2:=(-y-sqrt(D))/2*k;
writeln('x1=',x1);
writeln('x2=',x2);
end
else if D=0 then
begin
x:=-1y/2*k;
writeln('x=',x);
end
else
writeln('Нет вещественных корней');
end;
var
a,b,c :real;
begin
writeln('Введите коэфиценты a,b,c');
read(a,b,c);
solution(a,b,c);
end.
Новые вопросы
Английский язык,
2 года назад
Українська література,
2 года назад
Математика,
7 лет назад
Алгебра,
7 лет назад
История,
9 лет назад