Информатика, вопрос задал lelushv , 8 лет назад

Напишите программу ( в паскале авс), которая вычисляет число пи с заданной пользователем точностью. Воспользуйтесь данными и условием предыдущей задачи. (условие предыдущей задачи: Напишите программу, которая вычисляет частичную сумму ряда 1-1/3+1/5-1/7+1/9-... и сравнивает полученное значение с пи/4).

Ответы на вопрос

Ответил srzontmp
0
var s,sgn,eps: real;
    i: integer;
begin
  write('точность вычислений: ');
  readln(eps);
  s:=1;  sgn:= -1;
  i:=3;
  repeat
    s:=s+sgn/ i;
    sgn:= - sgn;
    i:=i+2;
  until 8/i<eps;
  writeln('число пи:  ',s*4);
  writeln('точное значение пи: ',pi);
end.    

точность вычислений: 1.0e-6
число пи:  3.14159240358966
точное значение пи: 3.14159265358979

Новые вопросы