Напишите программу в паскале abc, которую вводим последовательность целых чисел заканчивающуюся нулем и определяет верно ли что введеные элементы чередуют знаки, например (2, -2, 3, -3, 4, -4, 5, -5: да знаки чередуются) Не используя масивов. Либо объясните алгоритм действий
Ответы на вопрос
Ответил guslyakov98vaddam
0
program lol(input, output);
var b, a, a1:integer;
begin
a:=1;
b:=0;
a1:=-1;
repeat
begin
read (a);
if (a/((-1)*a))=(a1/a1) then
b:=b+1;
if a=0 then break;
read (a1);
if a <> (-1)*a1 then
b:=b+1;
end
until (a=0) or (a1=0);
if b>1 then
writeln ('Последовательность не верна')
else
writeln ('Последовательность верна');
end.
Ответил guslyakov98vaddam
0
writeln ('Знаки не чередуются' )
Ответил guslyakov98vaddam
0
else
Ответил guslyakov98vaddam
0
writeln ('Знаки чередуются');
Ответил guslyakov98vaddam
0
end.
Ответил Skorp818
0
Спасибо большое :) )
Новые вопросы