Напишите программу в Паскаль, пожалуйста
В одномерном массиве из 10 элементов вычислить произведение чётных и сумму нечётных.
Ответы на вопрос
Ответил Kalderone
0
program z1;
var a:array[1..10] of integer; i:integer; s,p:longint;
begin
p:=1;
for i:=1 to 10 do
read(a[i]);
for i:=1 to 10 do
if a[i] mod 2 = 0 then p:=p*a[i] else s:=s+a[i];
write('произведение четных = ',p,' сумма нечетных = ',s);
end.
var a:array[1..10] of integer; i:integer; s,p:longint;
begin
p:=1;
for i:=1 to 10 do
read(a[i]);
for i:=1 to 10 do
if a[i] mod 2 = 0 then p:=p*a[i] else s:=s+a[i];
write('произведение четных = ',p,' сумма нечетных = ',s);
end.
Новые вопросы