Напишите программу в Паскаль .
Где нужно ввести стоимость за 1 кг крупы .Вывести стоимость за 100.200.300 и так до 1000гр
Заранее спасибо .решите подробно .
Ответы на вопрос
Ответ:
Потому что идёт раздражение клеток и не будет меня любить и
Ответ:
program Ves;
var v,s: real;
begin
write ('Введите стоимость 1 кг крупы: ');
readln (s);
v := 100;
while v <= 1000 do
begin
writeln(v:4,' г крупы стоит ', v*s/1000:5,' y.e.');
v := v + 100
end
end.
Объяснение:
write ('Введите стоимость 1 кг крупы: '); - выводим на экран надпись
readln (s); - вводим значение стоимости за 1 кг крупы
v := 100; - задаём начальный вес
while v <= 1000 do - используем цикл с предусловием
begin - используем составной оператор
writeln(v:4,' г крупы стоит ', v*s/1000:5,' y.e.'); - выводим на экран надпись, используем форматированный вывод, формулу берем из пропорции
1000 г - s (стоимость 1 кг крупы)
v (вес) - ?
? = v * s / 1000
v := v + 100 - увеличиваем вес на 100
end - используем составной оператор