Информатика, вопрос задал Gruznadya , 10 лет назад

Напишите программу в Паскаль для решения задачи:
Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10

Ответы на вопрос

Ответил HRAshton
0
begin
  var s: string;
  var i, k: integer;
  readln(s);
  try
    foreach c: char in s do
      k += Byte.Parse(c);
    writeln(k);
  except
    on System.FormatException do
        writeln('Введи число -_-');
    else writeln('Ошибка');
  end;
end.
Новые вопросы