Информатика, вопрос задал Аноним , 10 лет назад

Напишите программу в паскаль  для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.

Ответы на вопрос

Ответил Mepkypuu
0
var a,b,c,d:real;
begin
readln(a,b,c,d);i
f (a<0) and (b/c=2) then
begin
writeln((a+b+c+d)/4);
if a*b*c*b>a+b+c+d then 
begin
writeln(a*b*c*b);
writeln(a+b+c+d);
end;
end
else
writeln(a*2,' ',b*2,' ',c*2,' ',d*2);
end.
Ответил Mepkypuu
0
если помог, то отметь как лучшее)
Ответил Аноним
0
уже)
Ответил Mepkypuu
0
ещё нет, вот смотри:http://znanija.com/task/4140702б там решение отмечено как лучшее
Ответил Mepkypuu
0
а ты просто спасибо нажал(
Новые вопросы