Напишите программу в паскаль. ДАМ 20 БАЛЛОВ!!!
Вывести на экран все нечетные числа меньше введенного x.
Вывести на экран все числа кратные 5 меньше введенного x.
Вывести на экран n четных чисел так, чтобы числа выводились в обратном порядке – от большего к 2.
Вывести на экран n нечетных чисел так, чтобы числа выводились в обратном порядке – от большего к 1.
Вывести на экран все цифры числа, введенного с клавиатуры.
Определить, сколько цифр в числе, введенном с клавиатуры.
Ответы на вопрос
Ответил Wybr
0
Ответ:
begin
//PascalABC.NET 3.8.2
var num := ReadInteger;
SeqWhile(1, x -> x + 2, x -> x < num).Println;
num := ReadInteger;
SeqWhile(5, x -> x + 5, x -> x < num).Println;
SeqGen(ReadInteger, 2, x -> x + 2).Reverse.Println;
SeqGen(ReadInteger, 1, x -> x + 2).Reverse.Println;
ReadInteger.ToString.ForEach(x -> Write(x, ' '));
Writeln;
ReadInteger.ToString.Length.Println;
end.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Алгебра,
7 лет назад
Қазақ тiлi,
7 лет назад
История,
8 лет назад