Информатика, вопрос задал gang70 , 7 лет назад

напишите программу в pascal
Сергей страдает ожирением в процессе голодании он каждую неделю скидывает 3% от предыдущего веса изначально он весил 150 кг в машину он влезет когда будет весить 96 кг Через сколько недель он влезет в машину?

Ответы на вопрос

Ответил omelaviscum
0

VAR  

MASSA:real;

NED:INTEGER;

BEGIN

MASSA:=150;

NED:=0;

WHILE (MASSA>=96) DO

BEGIN

MASSA:=MASSA-MASSA*0.03;

NED:=NED+1;

END;

WRITELN('Через ',NED,' недель Сергей влезет в машину')

END.

Ответил pryhodzichdavid
0

var v,z:real;

   i:integer;

begin

v:=150;

while not(v<=96) do

begin

z:=(v/100)*3;

v:=v-z;

inc(i);

end;

write(i);

end.

Новые вопросы