Информатика, вопрос задал Аноним , 9 лет назад

Напишите программу в Pascal , которая из трех введенных с клавиатуры чисел возводит в квадрат положительные, а отрицательные оставляет без изменения.

Ответы на вопрос

Ответил ИнформатикБУ
0
var
a, b, c: integer;
begin
readln(a, b, c); //вводим a b c
if a > 0 then writeln(a*a) //если a > 0 вывести квадрат a
else
writeln(a); //иначе вывести a
if b > 0 then writeln(b*b) //если b > 0 вывести квадрат b
else
writeln(b); //иначе вывести b
if c > 0 then writeln(c*c) //если c > 0 вывести квадрат c
else
writeln(c); //иначе вывести c
end.
Ответил Аноним
0
Работает?
Ответил ИнформатикБУ
0
да. могу прицепить скрин работы)
Ответил Аноним
0
Нет, благодарю, как проверю, отмечу как лучший ответ.
Ответил Аноним
0
Спасибо, братишка.
Новые вопросы