Напишите программу в pascal abc
Для первых n натуральных чисел вычислить сумму чисел, кратных 3 и сумму всех чисел.
Ответы на вопрос
Ответил Аноним
0
Var
n,S,S3:integer;
Begin
Write('n = ');
ReadLn(n);
For n:= 1 to n do
Begin
S:=S+n;
if n mod 3 = 0 then S3:=S3+n;
End;
WriteLn('Сумма чисел [1..',n,'], кратных трём: ',S3);
WriteLn('Сумма всех чисел [1..',n,']: ',S);
End.
n,S,S3:integer;
Begin
Write('n = ');
ReadLn(n);
For n:= 1 to n do
Begin
S:=S+n;
if n mod 3 = 0 then S3:=S3+n;
End;
WriteLn('Сумма чисел [1..',n,'], кратных трём: ',S3);
WriteLn('Сумма всех чисел [1..',n,']: ',S);
End.
Новые вопросы
Математика,
2 года назад
Алгебра,
8 лет назад
Алгебра,
8 лет назад
Химия,
9 лет назад
Алгебра,
9 лет назад