Информатика, вопрос задал elizmilash , 8 лет назад

Напишите программу в pascal abc
Для первых n двузначных натуральных чисел вывести суммы цифр каждого числа

Ответы на вопрос

Ответил Аноним
0
Var S,n,A:integer;
Begin
Write('n = ');ReadLn(n);
For n:= 10 to n+9 do
    Begin
    A:=n;
    S:=0;
    While A > 0 do
       Begin
       S:=S+A mod 10;
       A:= A div 10
       End;
    WriteLn('Сумма цифр ',n,' равна: ',S)
    End;
End.
Новые вопросы