Информатика, вопрос задал danicfandeev , 2 года назад

Напишите программу, в которой у пользователя запрашивается два четырёхзначных числа A и B. Затем выведите в порядке возрастания все четырёхзначные числа в интервале от A до B, запись которых содержит ровно три одинаковые цифры.

Ответы на вопрос

Ответил itsgest
2

a = input('Введите a: ')

b = input('Введите b: ')

c = 0

x = 0

a = a + b

a = list(a)

while len(a) != 0:

   if a.count(a[0]) == 3:

       if c == 0:

           c = x

       else:

           c += x

           a.remove(a[0])

   else:

       continue

print(c)

Новые вопросы