Другие предметы, вопрос задал etozhehaxy , 2 года назад

Напишите программу, в которой с экрана вводятся целые числа до тех пор, пока не будет введен ноль. Из введенных чисел найти минимальное положительное и его номер. Использовать массивы нельзя.

Ответы на вопрос

Ответил jopik228
0

Ответ:

var

max,a : integer;

begin

readln(a);

max := a;

repeat

readln(a);

if (a > max) and (a <> 0) then

max := a;

until a = 0;

writeln(max);

readln;

end.

Новые вопросы