Напишите программу в которой одномерный массив на 10 элементов , нужно заполнить по формуле только четными значениями. Выведите массив строчку. Найдите количество значений лежащих в промежутке [6 до 20] (включительно 20). Произведение тех, которые больше 10
Ответы на вопрос
Ответил Endok
0
var A:array[1..10] of Integer;
i,N,k,l,j:integer;
begin
Readln(N);
For i:=1 to N do
A[i]:=Random(1,10);
For i:=1 to N do
Write(A[i],' ');
Writeln;
For i:=1 to N do
If (A[i]>=6) and (A[i]<=20) then
k:=k+1;
Writeln('количество значений лежащих в промежутке [6 до 20] ',k);
For i:=1 to N-1 do
For j:=i+1 to N do
If A[i]*A[j]>10 then
l:=l+1;
Writeln('количество значений произведение которых больше 10',l);
end.
i,N,k,l,j:integer;
begin
Readln(N);
For i:=1 to N do
A[i]:=Random(1,10);
For i:=1 to N do
Write(A[i],' ');
Writeln;
For i:=1 to N do
If (A[i]>=6) and (A[i]<=20) then
k:=k+1;
Writeln('количество значений лежащих в промежутке [6 до 20] ',k);
For i:=1 to N-1 do
For j:=i+1 to N do
If A[i]*A[j]>10 then
l:=l+1;
Writeln('количество значений произведение которых больше 10',l);
end.
Новые вопросы
Қазақ тiлi,
2 года назад
Математика,
2 года назад
Литература,
9 лет назад
География,
9 лет назад
Физика,
9 лет назад
История,
9 лет назад