Информатика, вопрос задал stasbc20 , 1 год назад

Напишите программу, в которой объявите массив, состоящий из целых чисел С[10][10]. Присвойте элементам главной диагонали нули.​


NebniyWolf: питон
kozakgd8: пон
NebniyWolf: ой
NebniyWolf: c++
kozakgd8: ахахах
kozakgd8: інформатика, 1-4 класи, c++
NebniyWolf: и что
kozakgd8: u r genious
NebniyWolf: он выбрал просто так возраст менше 11
stasbc20: с++

Ответы на вопрос

Ответил rurionoris
0

Ответ: #include <iostream>

#include <ctime>

int main() {

   

   srand(time(nullptr));

   constexpr std::size_t rows = 10, cols = 5;

   int matrix[rows][cols];

   constexpr int min = -20;

   constexpr int max = 20;

   for (std::size_t i = 0; i < rows; ++i) {

       for (std::size_t j = 0; j < cols; ++j) {

           matrix[i][j] = min + (rand() % (max - min + 1));

           std::cout << matrix[i][j] << ' ';

       }

       std::cout << '\n';

   }

   for (std::size_t i = 0; i < rows && i < cols; ++i)

       matrix[i][i] = 0;

   std::cout << "Result:\n";

   for (std::size_t i = 0; i < rows; ++i) {

       for (std::size_t j = 0; j < cols; ++j) {

           std::cout << matrix[i][j] << ' ';

       }

       std::cout << '\n';

   }

   return 0;

}

Объяснение: Зависит от того, какой язык вам нужен.


NebniyWolf: c++ ему нужен
stasbc20: с++
rurionoris: в таком случае это он, вы можете найти этот массив, он принадлежит Nishen
stasbc20: не понял
rurionoris: Этот массив на C++, подобные вы можете найти в интернете от, например, NISHEN. Не уверен, что здесь можно указывать сторонние форумы.
Ответил kozakgd8
0

Ответ:

Объяснение:

короче вроде цикл должен выглядеть так:
for (int i=0; i<10; i++){
arr[i][i] = 0;

}


stasbc20: можно полный код?
Новые вопросы