Напишите программу в Delphi 7, к данной задаче или составьте математическую модель (напишите с помощью кода). Очень срочно, я не пойму это программирование ! Но нужно решить , на оценку ! Прикрепите пожалуйста в файле delphi чтобы я смог на компьютере открыть !
Приложения:

Ответы на вопрос
Ответил Aillianna
0
var
k, e, m, n: integer;
begin
readln(k, e, m, n);
if (k + e) mod 2 = (m + n) mod 2 then
writeln('Одного цвета')
else
writeln('Разных цветов');
if (k = m) or (e = n) then
writeln('Прямая ладья')
else
writeln('Косая ладья через ', k, ',', n);
end.
k, e, m, n: integer;
begin
readln(k, e, m, n);
if (k + e) mod 2 = (m + n) mod 2 then
writeln('Одного цвета')
else
writeln('Разных цветов');
if (k = m) or (e = n) then
writeln('Прямая ладья')
else
writeln('Косая ладья через ', k, ',', n);
end.
Ответил Animeshnikq
0
если вводить через пробел то числа просто в строчку пишутся бесконечно , я ввожу так цифра интер цифра интер цифра интер цифра интер потом вылезает окно с ошибкой
Ответил Animeshnikq
0
а теперь ввожу цифры 1 2 3 4 и она вообще быстро закрывается черное окно
Ответил Animeshnikq
0
Invalit nomerik imput
Ответил Aillianna
0
попробуй так. одно число за раз
Ответил Aillianna
0
var
k, e, m, n: integer;
begin
write('введите координату = ');read(k);
write('введите координату = ');read(e);
write('введите координату = ');read(m);
write('введите координату = ');read(n);
if (k + e) mod 2 = (m + n) mod 2 then
writeln('Одного цвета')
else
writeln('Разных цветов');
if (k = m) or (e = n) then
writeln('Прямая ладья')
else
writeln('Косая ладья через ', k, ',', n);
end.
k, e, m, n: integer;
begin
write('введите координату = ');read(k);
write('введите координату = ');read(e);
write('введите координату = ');read(m);
write('введите координату = ');read(n);
if (k + e) mod 2 = (m + n) mod 2 then
writeln('Одного цвета')
else
writeln('Разных цветов');
if (k = m) or (e = n) then
writeln('Прямая ладья')
else
writeln('Косая ладья через ', k, ',', n);
end.
Новые вопросы