Информатика, вопрос задал konakan2006 , 2 года назад

Напишите программу в абс паскаль которая поприветствует, посчитает сумму покупки и сдачу

Ответы на вопрос

Ответил daraprelj
0

var st,st1,st2,plata,sdacha:real;

var n,i:integer;

begin

i:=0;

st2:=0;

writeln('Здравствуйте!');

writeln('Сколько продуктов вы купили?');

readln(n);

writeln('Введите стоимость каждого продукта');

while i<>n do

begin

readln(st1);

st2:=st2+st1;

i:=i+1;

end;

writeln('Стоимость вашей покупки составила:',st2);

writeln('Сколько вы платите?');

readln(plata);

sdacha:=plata-st2;

writeln('Ваша сдача составила ',sdacha);

writeln('Спасибо за покупку,приходите ещё!');

end.

Приложения:
Новые вопросы