Информатика, вопрос задал ВасЁк27 , 9 лет назад

напишите программу увеличивающую каждый элемент матрицы (n,m) в 3 раза и сохраняющую результат в виде второй матрицы

Ответы на вопрос

Ответил andy777
0
Uses  
CRT;
Const  
nmax=40;  
mmax=40;
var  a,b:array[1..nmax,1..mmax] of integer;  
i,j,n,m:integer;
begin
ClrScr;
repeat  
write('N:=');  
Readln(n);
until n in [1..nmax];
repeat  
write('M:=');  
Readln(m);
until m in [1..mmax];
writeln('Исходный массив: ');
randomize;
for i:=1 to n do
begin  
for j:=1 to m do  begin  
a[i,j]:=random(10)-3;  
write(a[i,j]:5);  
b[i,j]:=a[i,j]*a[i,j]*a[i,j];  
end;
writeln;
end;
writeln('Результирующий массив: ');
for i:=1 to n do
begin  
for j:=1 to m do  
begin  
write(b[i,j]:5);  
end;
writeln;
end;
readkey
end.
Ответил andy777
0
program mr;
var i,j,n,m,g: byte;
a,b: array[1..10,1..10] of integer;
begin
writeln('Введите размер массива n<10 и m<10 :');Read(n,m);
writeln('Заполняем матрицу : ');
for i:=1 to n do
for j:=1 to m do
begin
Read(a[i,j]); b[i,j]:=1;
for g:=0 to 2 do b[i,j]*=a[i,j];
end;
writeln('');
for i:=1 to n do
for j:=1 to m do writeln('м1 : ',a[i,j], ' м2 : ',b[i,j]);
end.
Ответил ВасЁк27
0
for g:=0 to 2 do b[i,j]*=a[i,j]; после квадратных скобок точно верно??? пишет что какое действие должно быть
Новые вопросы