Информатика, вопрос задал KeeerillSenpai , 7 лет назад

Напишите программу угадывания пароля с использованием цикла WHILE
(повторять ввод пароля пользователем, пока он не совпадёт с тем, который "зашифрован в программе")

Ответы на вопрос

Ответил nikitajurik3
0

Ответ:

var

pin : integer;

readPin : integer;

 

begin

 pin := 1234; //здесь напишешь  свой пин

  writeln('Write Pin :');

 readln(readPin);

 while readPin <> pin do begin

   writeln('Error wrong pin!');

   readln(readPin);

 end;

end.

Объяснение:

Вот

Ответил mihailovmikael
0

import random

code = ["954321"]

mineC = []

final = ""

i = 0

while True:

   while i < 6:

       wordC = random.randint(0, 9)

       mineC.append(wordC)

       i += 1

   if mineC != code:

       print(mineC)

       mineC.clear()

   if mineC == code:

       for i in mineC:

           final += i

       break

Работает только с паролями с цифрами

иначе придется выстраивать буквы по індексу и вызывать их так

   

Новые вопросы