Информатика, вопрос задал kirane , 10 лет назад

напишите программу удаляющая из текста все буквы совпадающие с его последней буквой

Ответы на вопрос

Ответил yasadc
0
uses crt;
var s:string;
n,i:integer;
begin
readln(s);
n:=length(s);
for i:=1 to n do
if s[i]=s[n] then delete(s,i,1);
writeln(s);
end.

Эта программа рассчитана на то, что удаляется и последний символ тоже

Ответил kirane
0
ага , сейчас проверю
Ответил Segrif
0
var s:string; i:integer;
begin
read(s);
i:=1;
while i<length(s) do
if s[i]=s[length(s)] then s:=copy(s,1,i-1)+copy(s,i+1,length(s)-i)
else i+=1;
write(s)
end.
Ответил kirane
0
оо, у тебя не удаляет, я незнаю какой точно переписывать
Ответил Segrif
0
А, у вас обычный или .net? Если обычный, то лучше другой вариант.
Ответил kirane
0
обычный
Новые вопросы