Информатика, вопрос задал voloclocin , 1 год назад

Напишите программу, создающую диалог с компьютером на тему «Магазин». Б.а. В этой программе вы также будете использовать функцию цикла while. Спросите пользователя, какой продукт он хочет купить, и когда он введет название продукта, он ответит: «Какой еще продукт?» появится вопрос, и пользователь должен написать новый продукт. Когда пользователь вводит слово «достаточно», перечислите все элементы, начиная со «Список ваших покупок:» и заканчивая «Большое спасибо!!» PYTHON только само решение

Ответы на вопрос

Ответил CallMeShepard
0

# Эта программа создает диалог с компьютером на тему «Магазин».

# Переменная используется для хранения товаров, которые будут куплены.

items = []

print("Добро пожаловать в магазин!")

# Задать пользователю вопрос о товаре, который он хочет приобрести.

item = input("Что вы хотите купить? ")

# Добавить покупку в список продуктов.

items.append(item)

# Задать пользователю повторный вопрос о товаре, который он хочет приобрести.

# Цикл while работает до тех пор, пока пользователь не введет слово «достаточно».

while True:

   item = input("Для продолжения покупок введите название продукта, а для завершения - «достаточно»: ")

   if item == "достаточно":

       break

   items.append(item)

# Вывести пользователю список продуктов, которые он купил  

print("Список ваших покупок:")

for item in items:

   print(item)

print("Большое спасибо!! С вами было приятно иметь дело!")


CallMeShepard: P.S. Если не нужно строки с комментариями # можно удалить
Новые вопросы