Напишите программу сложения двух простых дробей (без сокращения дроби). С клавиатуры
вводятся значения 4 переменных: числитель и знаменатель первой дроби и числитель и
знаменатель второй дроби. На экран выводится 2 числа: Числитель полученной дроби и
знаменатель.
Ответы на вопрос
Ответил micro2002
0
Paskal ABC
uses CRT;
var a, b, c, d, e, f:integer;
begin
readln(a, b, c, d);
e:=(d*a)+(c*b);
f:=b*d
writeln(e,' ', f);
end.
Ответил VipPhoenixVip
0
var a,b,c,d:real;
c1, c2, z1, z2:real;
begin
write('Введи числитель первой дроби: '); read(a);
write('Введи знаменатель первой дроби: '); read(b);
write('Введи числитель второй дроби: '); read(c);
write('Введи знаменатель второй дроби: '); read(d);
write(a + ' / ' + b + ' + ' + c + ' / ' + d + ' = ');
if(b = d) then begin
c1 := a + c;
write(c1 + ' / ' + b);
End else Begin
z1 := b * d;
c1 := (z1 / b) * a;
c2 := (z1 / d) * c;
z2 := c1 + c2;
write(z2 + ' / ' + z1);
end;
end.
Ответил VipPhoenixVip
0
(без сокращения дроби)
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
Математика,
9 лет назад
Математика,
9 лет назад